Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Updated the Forum Rules and Guidelines (02/29/20); Blog post: GIF Roundup (04/11/20)

Pages: 1 ... 3 4 [5]

Author Topic: [0.9.1a] Hyperdrive v2.0.0 - Fast and engaging long distance travel  (Read 42677 times)

Sundog

  • Admiral
  • *****
  • Posts: 1098
    • View Profile
Re: [0.9.1a] Hyperdrive 1.1.2 - Fast and engaging long distance travel
« Reply #60 on: May 19, 2020, 09:23:29 PM »

Hyperdrive 2.0.0
NOT compatible with previous versions!
This update is save-breaking, meaning any save that used an older version of this mod will not work with this version or any future version.


Fixed a crash that would occur after saving when devMode was set to true in settings.json (but not when devMode was activated via console for some reason)
Increased the duration that fleets can't engage after hyperwarp from 2.5 seconds to 3.0

My apologies for the longstanding crash, and many thanks to Wispborne for identifying it! Unfortunately, fixing it necessitated a save-breaking change.

Faremann

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #61 on: May 25, 2020, 09:29:41 AM »

i am getting null error message after upgrading to 2.0 and starting a new game.didn't have that one with the older versions so for now downgrading again
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1098
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #62 on: May 25, 2020, 11:25:31 AM »

I didn't get any errors just now when I tried starting a new game and messing around a bit (saving, loading, and using hyperdrive a few times).

Would you mind posting the error message? You can find it at the end of the log (Starsector/starsector-core/starsector.log) after the error occurs.

Faremann

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #63 on: May 25, 2020, 11:52:52 AM »

hope thats the right one

Spoiler
194728 [Thread-4] ERROR hyperdrive.ModPlugin  - null
    com.fs.starfarer.settings.B.setColor(Unknown Source)
    hyperdrive.campaign.abilities.HyperdriveAbility.resetSprite(HyperdriveAbility.java:465)
    hyperdrive.campaign.abilities.HyperdriveAbility.activateImpl(HyperdriveAbility.java:180)
    com.fs.starfarer.api.impl.campaign.abilities.BaseDurationAbility.activate(BaseDurationAbility.java:220)
    hyperdrive.campaign.abilities.HyperdriveAbilityAI.advance(HyperdriveAbilityAI.java:228)
    com.fs.starfarer.campaign.ai.ModularFleetAI.advance(Unknown Source)
    com.fs.starfarer.campaign.fleet.CampaignFleet.advance(Unknown Source)
    com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
    com.fs.starfarer.campaign.StarSystem.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Unknown Source)
[close]
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1098
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #64 on: May 25, 2020, 01:33:47 PM »

Yup, that's the right one, thanks! It looks like one of the colors the mod uses isn't defined, but, looking at the code, that shouldn't be possible. I tried reinstalling hyperdrive from the linked file just in case there was a problem with it that my local version doesn't have, but I still didn't get any errors when I started a new game. The only thing I can think of is that something went wrong when you updated, such as a corrupted download or maybe overwriting the old mod folder instead of deleting it first.

Normally I would ask what other mods you're using and if there are any other factors involved that might be part of what causes the issue, but there's no way for weird interactions to occur in this case. Could you try deleting the current installation and re-downloading it?

Faremann

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #65 on: May 25, 2020, 01:49:12 PM »

there is one thing  that COULD potentially  be related to my files. i did change the color of  the hud from white to a purple in the config. could that be the source of the problem ?
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1098
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #66 on: May 25, 2020, 01:58:54 PM »

I don't think so. This particular color is hard-coded, so configuration files shouldn't affect it. But if you like, I could try using your file to see if I can reproduce the issue with it.

Faremann

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #67 on: May 25, 2020, 02:17:48 PM »

if i recall right (its been months since i did the modification) it should be the attached file. to save you some time its in  \Starsector\starsector-core\data\world\factions
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1098
    • View Profile
Re: [0.9.1a] Hyperdrive 2.0.0 - Fast and engaging long distance travel
« Reply #68 on: May 25, 2020, 07:27:03 PM »

Still no luck reproducing the issue after using your file. Did you try reinstalling?
Pages: 1 ... 3 4 [5]