Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: ATI Graphics Cards on Linux  (Read 4495 times)

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
ATI Graphics Cards on Linux
« on: August 16, 2011, 05:29:57 PM »

If you're running Starfarer using an ATI graphics card on Linux, you might experience the game crashing shortly after startup. To get around this:

1. Install OpenJDK.
2. Modify starfarer.sh to launch the OpenJDK java. In most cases, just change the first line from
Code
./jre_linux/bin/java ...
to
Code
java ...

This will run the game using your default jvm. You can see which one that is if you type "java -version" in the console. If that's not the OpenJDK jvm, change starfarer.sh to point to your OpenJDK java executable.

If the above does not work try the official ATI drivers in addition to running with OpenJDK.
« Last Edit: August 21, 2011, 04:38:10 PM by Alex »
Logged

charlieb

  • Ensign
  • *
  • Posts: 12
    • View Profile
Re: ATI Graphics Cards on Linux
« Reply #1 on: August 16, 2011, 05:43:44 PM »

If you're not using the official ATI catalyst driver then try just doing the openJDK switch first.

You may not need to use the catalyst driver if you don't want to.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
Re: ATI Graphics Cards on Linux
« Reply #2 on: August 21, 2011, 04:38:32 PM »

Thanks for the additional info - updated original post.
Logged

Despo

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: ATI Graphics Cards on Linux
« Reply #3 on: February 25, 2012, 01:50:06 AM »

I have the crash
running ATI proprietary catalyst driver

I changed starfarer.sh to use "java"

my java versions
Quote
# update-alternatives --config java

There are 6 programs which provide 'java'.

  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
 + 2           /usr/lib/jvm/jre-1.6.0-openjdk/bin/java
*  3           /usr/java/jre1.6.0_28/bin/java
   4           /usr/java/jdk1.6.0_28/jre/bin/java
   5           /usr/java/jre1.6.0_29/bin/java
   6           /usr/java/jdk1.6.0_29/jre/bin/java


console output
OpenJDK crashlog
Sun java crashlog
(lame attachment limits guys...)

so anyway... hope someone can help me out
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
Re: ATI Graphics Cards on Linux
« Reply #4 on: February 25, 2012, 09:37:03 AM »

Hi - sorry about the trouble!

Stupid question, because I have to ask - is the catalyst driver up-to-date?
Logged

figvam

  • Lieutenant
  • **
  • Posts: 70
    • View Profile
Re: ATI Graphics Cards on Linux
« Reply #5 on: February 25, 2012, 08:40:01 PM »

For what it's worth, I experienced absolutely the same crash with Catalyst 11-12 and Fedora 14 x86 (game crashed right after the main menu screen faded in), and it went away after I upgraded to the latest Catalyst 12-1.
Logged