Fractal Softworks Forum
November 18, 2017, 09:38:44 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New blog post: Economy & Outposts (9/19/17); Starsector 0.8.1a is out!
 
   Home   Help Search Login Register  
Pages: 1 ... 78 79 [80] 81 82 83
  Print  
Author Topic: [0.8.1a] Neutrino Corp. (v. 1.84RC3)  (Read 360428 times)
Sir Goose
Ensign
*
Posts: 15


View Profile
« Reply #1185 on: May 10, 2017, 04:24:52 PM »

Has anyone else found the Neutrino frigates to be a bit under powered? I've been playing with them a little bit and I haven't found a way to get them to work. When compared to fast frigates like the Tempest, I don't see much of a contest. Yes having high armor and comparatively strong shields is a great benefit, but when a frigate can literally be kited to death by some fast destroyers I think that the frigate is lacking the major advantages that keeps other frigates alive --speed and maneuverability.

On another note, thank you so much for the update to 0.8a! I can only play vanilla Star Sector for so long until I start to crave some faction mods!
Logged
ApetureUnicorn
Ensign
*
Posts: 24


View Profile Email
« Reply #1186 on: May 12, 2017, 02:16:24 AM »

Hey, Mac user here, my game crashes every time i come into contact ( simulations/combat ) with the neutrino factions ships. This could be a weapons thing with the grpahicslib and the fact that im a mac user but i've checked that i've downloaded all the libs needed. When the game crashes it comes up with this message.
Fatal: com/fs/starfarer/combat/systems/H
Cause: com.fs.starfarer.combat.systems.H
Check.starsector.log for more info.

I feel like something has flown right over my head but I cant seem to see it.
I really love the art style and the design of the ships and would love to keep playing with them.
Any tips with fixing the problem?
Logged
Takion Kasukedo
Captain
****
Posts: 375


The Embodiment of Defilement, TakionKasukedo


View Profile
« Reply #1187 on: May 12, 2017, 04:21:37 AM »

Has anyone else found the Neutrino frigates to be a bit under powered? I've been playing with them a little bit and I haven't found a way to get them to work. When compared to fast frigates like the Tempest, I don't see much of a contest. Yes having high armor and comparatively strong shields is a great benefit, but when a frigate can literally be kited to death by some fast destroyers I think that the frigate is lacking the major advantages that keeps other frigates alive --speed and maneuverability.

On another note, thank you so much for the update to 0.8a! I can only play vanilla Star Sector for so long until I start to crave some faction mods!

Well, unless you're not talking about the Casuality (The Phase Frigate) then, yeah, kind of.

Relativity is a showcase of this, it's not very powerful, barely has OP available, and can't stand up against a Lasher most of the time.
Logged

The Embodiment of Defilement reigns over his part of the galaxy.

FEAR THE CASCADE.
Zenobious
Ensign
*
Posts: 20


View Profile
« Reply #1188 on: May 12, 2017, 11:33:14 AM »

Hey, Mac user here, my game crashes every time i come into contact ( simulations/combat ) with the neutrino factions ships. This could be a weapons thing with the grpahicslib and the fact that im a mac user but i've checked that i've downloaded all the libs needed. When the game crashes it comes up with this message.
Fatal: com/fs/starfarer/combat/systems/H
Cause: com.fs.starfarer.combat.systems.H
Check.starsector.log for more info.

I feel like something has flown right over my head but I cant seem to see it.
I really love the art style and the design of the ships and would love to keep playing with them.
Any tips with fixing the problem?

Try checking the version of SS you have against the latest available for download -- I had a similar error when I first tried to use the Neutrino mod, and updating SS fixed it. There was a mini-patch at one point after the 0.8 release, and I'm pretty sure Neutrino will only work with the absolute latest version.
Logged
sirboomalot
Admiral
*****
Posts: 596


Boom


View Profile Email
« Reply #1189 on: May 15, 2017, 08:33:17 PM »

17058725 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NoClassDefFoundError: com/fs/starfarer/combat/systems/H
java.lang.NoClassDefFoundError: com/fs/starfarer/combat/systems/H
   at data.hullmods.NeutrinoSigmaUpgrade.advanceInCombat(NeutrinoSigmaUpgrade.java:197)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: com.fs.starfarer.combat.systems.H
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   ... 9 more

I was being aided by a neutrino fleet against the templar when this happened.

EDIT: Whoops, just realized I've been playing .8a RC18 instead of RC19...
« Last Edit: May 17, 2017, 10:02:59 AM by sirboomalot » Logged
ahrenjb
Commander
***
Posts: 209



View Profile
« Reply #1190 on: May 18, 2017, 04:18:02 PM »

I feel like the sprites for the various versions of the Piledriver need a rework. The cargo one is ok, but still shares the same problem as the rest of them. It's a little tooo stick-like. The carrier version especially, the forward arm needs to be like, 50-100% wider to look natural with the way flight decks are integrated in the rest of the game.

Also, 3 is just too many for that size carrier.
Logged
Absolutecero
Ensign
*
Posts: 30


View Profile Email
« Reply #1191 on: May 18, 2017, 04:58:47 PM »

Hey I have been enjoying this mod a lot but I have recently been having trouble fighting them when ever I fight this bounty neutrino fleet I get this error.

  java.lang.IllegalArgumentException: Color parameter outside of expected range: Red Green Blue
   at java.awt.Color.testColorValueRange(Unknown Source)
   at java.awt.Color.<init>(Unknown Source)
   at java.awt.Color.<init>(Unknown Source)
   at data.scripts.weapons.NeutTractorbeamEffect.advance(NeutTractorbeamEffect.java:35)
   at com.fs.starfarer.combat.entities.ship.A.void.advance(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.o00000(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)


I have been fighting them with a mostly dassault ship fleet . any help.
Logged
Orikson
Captain
****
Posts: 278

Always Seen on Discord


View Profile Email
« Reply #1192 on: May 20, 2017, 08:44:20 AM »

It's been a while since I've posted any bug reports, but here's one that sort of interesting and brought to my attention by another player.

This is related to all phase ships in the Neutrino line up. They all act normal until they reach 80% flux, whereby the weird thing began.

All the phase ships cannot phase through any object (asteroids, ships so far from observation) at that point.

They get repulsed to the outer edges and some hidden boundary.

I managed to break this though by using TheEND because of it's ability to remain in phase after it reaches 80%. By forcing the controls to not get pushed to the boundaries, I prevented it at the cost of jamming it into the spot endlessly until the ship runs out of CR.

Summary: The Neutrino phase ships start to act weird once they reach 80% flux. They can't phase through enemies and asteroids at that point.

That's all from me.
Logged

"A story teller and a trader. Tell me your tales and I'll tell you no lies."

Come join the Starsector Fan Chat! It's decently active.

Link: https://discord.gg/eb5UC
SierraTangoDelta
Commander
***
Posts: 138


Who could it be?


View Profile
« Reply #1193 on: May 22, 2017, 12:21:32 PM »

Hey, which Neutrino ships are not available in the current version? Falken and the [coding joke] ship, right? Can I add them to the generation lists, or will I have to console command them in?
Logged
Death_Silence_66
Commander
***
Posts: 161


View Profile
« Reply #1194 on: May 26, 2017, 04:12:33 PM »

The Neutrino missions are incredibly difficult. Special Delivery is harder than forlorn hope.
Logged
ahrenjb
Commander
***
Posts: 209



View Profile
« Reply #1195 on: May 27, 2017, 07:18:02 AM »

Hey I have been enjoying this mod a lot but I have recently been having trouble fighting them when ever I fight this bounty neutrino fleet I get this error.

 
Code:
java.lang.IllegalArgumentException: Color parameter outside of expected range: Red Green Blue
at java.awt.Color.testColorValueRange(Unknown Source)
at java.awt.Color.<init>(Unknown Source)
at java.awt.Color.<init>(Unknown Source)
at data.scripts.weapons.NeutTractorbeamEffect.advance(NeutTractorbeamEffect.java:35)
at com.fs.starfarer.combat.entities.ship.A.void.advance(Unknown Source)
at com.fs.starfarer.combat.systems.oOoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.o00000(Unknown Source)
at com.fs.starfarer.combat.systems.oOoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.advance(Unknown Source)
at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I have been fighting them with a mostly dassault ship fleet . any help.

I've been getting this error on occasion as well, but I haven't been able to reproduce it reliably. Opening up the NeutTractorbeamEffect.java file shows this on line 35

Code:
coreColor = new Color((int) (255 * coreAlpha), (int) (255 * coreAlpha), (int) (255 * coreAlpha));

But I don't know how or why this would cause the crash. I have no scripting knowledge, anyone that can help?
Logged
Ryu116
Lieutenant
**
Posts: 52



View Profile Email
« Reply #1196 on: May 27, 2017, 04:44:06 PM »

Hello everyone,

I have been testing this awesome mod and I am experiencing CTD with one of weapon.  I am not sure if this weapon is actually from this mod or not.  If it is not, then forgive me.  However, here is picture of gun I am having problems with:



And here is error from starsector.log

https://pastebin.com/2iG0vjnT

Here is the list of mod I have installed (just in case if you need to know what I currently have installed.)

AAA_EZFaction
AAA_Starsector_FX_mod
Arsenal Expansion
Artefact
ATX
Audio Plus
Combat Chatter
Common Radar
Console Commands
Dassault-Mikoyan Engineering
Degenerate Portrait Pack
DIABLEAVIONICS
DisassembleReassemble_v0.4
ExplorerSociety
GKsec
GraphicsLib
Hegemony Expeditionary Auxiliary
Ifed Legacy
Interstellar Imperium
LazyLib
Leading Pip
LOGH
Looters
Neutrino corp
Oculian Berserks
ORA
Portrait pack
Power Dolls
Power Dolls 2
Shadowyards
ss-nom
Templars
Tore Up Plenty
UnknownSkies
UpgradedRotaryWeapons
Version Checker

Hopes this help for finding the bugs.  If it is caused by having too many mods, then it is my fault.  I will clean up mod list and reduce the numbers of mods installed for now until 0.8.1.
Logged
ahrenjb
Commander
***
Posts: 209



View Profile
« Reply #1197 on: May 27, 2017, 04:46:29 PM »

I think you need to try deleting, and re-extracting a fresh copy of the Neutrino directory. Don't just copy over.
Logged
Ryu116
Lieutenant
**
Posts: 52



View Profile Email
« Reply #1198 on: May 27, 2017, 05:24:33 PM »

I think you need to try deleting, and re-extracting a fresh copy of the Neutrino directory. Don't just copy over.

Thank you for the advice and unfortunately, I got the exactly same error after doing these following steps:

1) Deleted Neutrino Corp. folder from mods folder in Starsector folder
2) Re-downloaded mod and extracted it, and then moved it into mods folder
3) Ran the game, I could install and fire any weapons from Neutrino except for Triple Neutron Pulse Cannon.  Whenever I fire that cannon, I crashed to the desktop with the same error message:

https://pastebin.com/2iG0vjnT
Logged
PokerChen
Ensign
*
Posts: 10


View Profile Email
« Reply #1199 on: May 29, 2017, 10:51:14 AM »

Tested this triple neutron pulse cannon in the mission "Retribution" and the one after that, replacing other weapons. Worked just fine. You'll have to deactivate some mods and figure out if it's a mod-mod conflict. For reference, I have:
- combat chatter
- console commands
- Diable
- GraphicsLib
- LazyLib
- Neutrino
- ORA
- Portraits Pack
- Shadowyards
Logged
Pages: 1 ... 78 79 [80] 81 82 83
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!