Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: 64bit Arch Linux - no sound in game [SOLVED]  (Read 8199 times)

proff_ch405

  • Ensign
  • *
  • Posts: 2
    • View Profile
64bit Arch Linux - no sound in game [SOLVED]
« on: April 03, 2012, 07:45:20 PM »

First of all, hello all!  I just found this game the other day and had some fun playing it on my windows 7 laptop.  Now I am trying to get it going on my 64-bit Arch Linux setup and things seem to be working except for sound.

I have alsa configured and sound works for movies, music, and desktop sound effects....but not in Starfarer.  Is there a setting buried someplace that could be causing the game to try to use a different sound output?  My monitor is connected via HDMI, and my sound is setup to come out the analog port and feed some external speakers.

Any assistance would be appreciated!

Thanks!
« Last Edit: April 04, 2012, 04:45:46 AM by proff_ch405 »
Logged

Zilerrezko

  • Commander
  • ***
  • Posts: 246
    • View Profile
    • Email
Re: 64bit Arch Linux - no sound in game
« Reply #1 on: April 03, 2012, 09:16:55 PM »

what's like on a linux?
Logged

Ivaylo

  • Loremaster
  • Global Moderator
  • Commander
  • *****
  • Posts: 230
    • View Profile
Re: 64bit Arch Linux - no sound in game
« Reply #2 on: April 04, 2012, 04:19:20 AM »

Hi there!

Starfarer uses OpenAL as its sound system. In the past we have run across distros that were not properly bundled with the 64 bit binaries for OpenAL.

This is what worked for me to fix the issue in the past:

Open Synaptic Package Manager (System -> Administration -> Synaptic Package Manager)
Then in the search box type "libopenal" without the quotes.

Then click on the libopenal1 checkbox there, it ought to install the package in your OS. Our bundled .so file ought to have worked, but if this fixes sound we know where the issue is.


Hopefully that helps.
Logged
Escort Ship-level forum support

proff_ch405

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: 64bit Arch Linux - no sound in game [SOLVED]
« Reply #3 on: April 04, 2012, 04:45:28 AM »

Thanks for the heads up on OpenAL!

What I had to do on Arch LInux was the following:

pacman -S lib32-alsa-lib lib32-openal
Logged

Ivaylo

  • Loremaster
  • Global Moderator
  • Commander
  • *****
  • Posts: 230
    • View Profile
Re: 64bit Arch Linux - no sound in game [SOLVED]
« Reply #4 on: April 04, 2012, 07:03:43 AM »

So did that work? You have sound now?

If so, I will be quite content  ;D


EDIT: Derp, didn't see edited post title. I AM QUITE CONTENT.
Logged
Escort Ship-level forum support