Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: CTD - Newbie here  (Read 90 times)

Red_Zebra3

  • Ensign
  • *
  • Posts: 2
    • View Profile
CTD - Newbie here
« on: October 17, 2020, 03:11:22 AM »

First post ever here

I basically created a new save, found a system I liked and edited a planet with console commands. Shortly after (mostly when opening that save later) i get a CTD. The game runs fine if a start a normal game and i dont edit planets btw. Any help is apreciated since I dont know much about solving this issues

Here is the CTD log:

41675 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.api.impl.campaign.intel.SurveyPlanetIntelCreator.initPicker(SurveyPlanetIntelCreator.java:46)
   at com.fs.starfarer.api.impl.campaign.intel.SurveyPlanetIntelCreator.pickPlanet(SurveyPlanetIntelCreator.java:72)
   at com.fs.starfarer.api.impl.campaign.intel.SurveyPlanetIntelCreator.createMission Intel(SurveyPlanetIntelCreator.java:19)
   at com.fs.starfarer.api.impl.campaign.intel.GenericMissionManager.createEvent(GenericMissionManager.java:132)
   at com.fs.starfarer.api.impl.campaign.intel.BaseEventManager.advance(BaseEventManager.java:141)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Enabled Mods:

{"enabledMods": [
  "Another Portrait Pack -ReWork-",
  "timid_admins",
  "capturecrew",
  "aaCari UIp",
  "CombatAnalytics",
  "chatter",
  "timid_commissioned_hull_mods",
  "sun_fuel_siphoning",
  "ZGrand Sector",
  "deconomics",
  "interestingportraitspack",
  "lw_lazylib",
  "leadingPip",
  "MagicLib",
  "Mayasuran Navy",
  "nexerelin",
  "wyv_planetaryShieldAccessControl",
  "playerflagpack",
  "bonomel_skilledup",
  "sun_starship_legends",
  "Terraforming and Station Construction",
  "US",
  "lw_version_checker",
  "shaderLib"
]}
Logged

Histidine

  • Admiral
  • *****
  • Posts: 2802
    • View Profile
    • Bitbucket profile
    • Email
Re: CTD - Newbie here
« Reply #1 on: October 17, 2020, 05:43:57 PM »

Did you add any planet conditions to the modified planet? The error log suggests one or more of them was not an actually existing condition.
Logged

Red_Zebra3

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: CTD - Newbie here
« Reply #2 on: October 18, 2020, 03:04:29 AM »

What i meant by editing planets was just add some conditions and remove others so yeah, I did.

After testing a bit it seems to be it was about the way I was doing it.
I tend to customize my playthroughs, and when I modify the planets I do it without doing surveys and just leave them that way, after testing a bit if I do the changes after the survey it doesnt seem to crash.

I belive that modifying the planets without a survey makes the save go nuts and crash, could this be it?
« Last Edit: October 18, 2020, 03:55:49 AM by Red_Zebra3 »
Logged