Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Game Freezes (But Is Still Visually Responsive) When Entering Systems  (Read 90 times)

TestUserPleaseIgnore

  • Ensign
  • *
  • Posts: 2
    • View Profile

What Happens
After a bit of time from the start of a game (not long at all - maybe a little over an hour), whenever I enter a system the game freezes. However, I can still move the mouse and animations and music are still playing. It's just that I cannot control anything, the UI disappears, and the game doesn't progress. I've left it like this for several minutes, but nothing changed, then I just quit out. The only exception that I can find in starsector.log is WARN  data.scripts.campaign.intel.VayraPersonBountyManager  - org.json.JSONException: JSONObject["weight"] is not a number, which is only a warning-level message, and removing Vayra's Sector doesn't actually fix the issue. This is repeatable and happened whenever I load the game, and seems to happen with any system I enter.

starsector.log (from loading the save until the end): https://pastebin.com/d2fTSzYY

Active Mods:
Code
{"enabledMods": [
  "$$$_lightshow",
  "raccoonarms",
  "lw_autosave",
  "blackrock_driveyards",
  "lw_console",
  "istl_dam",
  "DisassembleReassemble",
  "ZGrand Sector",
  "interestingportraitspack",
  "Imperium",
  "kadur_remnant",
  "lw_lazylib",
  "MagicLib",
  "nexerelin",
  "ORA",
  "shadow_ships",
  "bonomel_skilledup",
  "speedUp",
  "sun_starship_legends",
  "underworld",
  "US",
  "vayrasector",
  "vayrashippack",
  "shaderLib"
]}

Things I've Tried
  • Ram is set to 4GB min/max
  • Everything in GraphicsLib is set to false
  • I disabled Vayra's Sector to see if that changed anything, but no
Other Information: I'm running the Mac version on 10.14.2

How to Help
Does anyone have advice on fixing the issue? My next step is to disable large swaths of mods at a time and see if the issue persists (Woe, my multitude of factions and ships!). If anyone has advice on what mods to remove first, or mods that might be interacting poorly, that would also be helpful.

Thanks!

« Last Edit: October 05, 2020, 01:03:59 PM by TestUserPleaseIgnore »
Logged

TestUserPleaseIgnore

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: Game Freezes (But Is Still Visually Responsive) When Entering Systems
« Reply #1 on: October 06, 2020, 11:12:08 AM »

I may have stumbled upon a partial solution: Starting/loading a different game, then loading the crashing game seems to fix the issue. It might be some weird state the game is getting into that the "Continue" button preserves versus regular loading? It's just speculation at this point, but I'll tinker around more if it happens again.
Logged