Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Launcher not saving enabled mods  (Read 214 times)

AcaMetis

  • Ensign
  • *
  • Posts: 33
    • View Profile
Launcher not saving enabled mods
« on: October 01, 2020, 05:59:41 AM »

I open the launcher, click on Mods..., enable the ones I want to enable, and hit save, but the launcher doesn't actually save them. The game will launch with all the mods active after I manually enable them, and ingame everything seems to work just fine, but I have to manually enable every mod every time I launch the game. Not that I have a huge list, but if there's a simple way to fix this I'd prefer to fix it.

For what it's worth I'm running Windows 10, and I'm using these mods:
-Adjusted Sector 0.2.2
-LazyLib 2.4f
-Luddic Enhancement 1.2.2
-Nexerelin 0.9.7b
-Terraforming and Station Construction 5.4.5
-Unknown Skies 0.42
Logged

Histidine

  • Admiral
  • *****
  • Posts: 2818
    • View Profile
    • Bitbucket profile
    • Email
Re: Launcher not saving enabled mods
« Reply #1 on: October 03, 2020, 01:38:30 AM »

The current modlist is saved in mods/enabled_mods.json.
Is the file/folder not writable? Try checking if it's read-only (right-click -> Properties in Windows).
Logged

AcaMetis

  • Ensign
  • *
  • Posts: 33
    • View Profile
Re: Launcher not saving enabled mods
« Reply #2 on: October 03, 2020, 03:28:19 AM »

Turns out that it is indeed set to read-only, but despite letting me disable that it doesn't actually save the change, and when I try to do it to a higher folder (say the Starsector folder itself) Windows yells at me for not being an administrator...which I am. This is my personal computer that no one else uses, so I'm logged in as an admin. It says it'll let me make the change, but than it doesn't actually do it.

What's the exact text that my enabled_mods.json should have? Maybe if I add it myself it'll work, and that sounds like a more likely scenario than someone knowing how to make Windows 10 less of an obtuse OS designed to suck me dry of all the bottomless pits of money I don't have.
Logged

Histidine

  • Admiral
  • *****
  • Posts: 2818
    • View Profile
    • Bitbucket profile
    • Email
Re: Launcher not saving enabled mods
« Reply #3 on: October 03, 2020, 03:48:30 AM »

The file looks like this:
Code: json
{"enabledMods": [
  "lw_autosave",
  "chatter",
  "lw_radar",
  "lw_console",
  "lw_lazylib",
  "MagicLib",
  "nexerelin",
  "lw_version_checker",
  "shaderLib"
]}
(I dunno if manually filling all that in is a good idea, especially since a typical playing modlist will be several times longer than this)

Did you move the game folder after installation? If so, reinstalling straight to the desired directory might set permissions correctly.
Logged

AcaMetis

  • Ensign
  • *
  • Posts: 33
    • View Profile
Re: Launcher not saving enabled mods
« Reply #4 on: October 03, 2020, 04:04:35 AM »

Right now I'm only using six mods, so manually filling it in shouldn't be horrible. Assuming I can figure out where to find the mod IDs or whatever that list uses.

...And as soon as I go to make that file I find it already made and waiting for me, despite the mods folder still saying it's read-only, because...mysterious reasons, I guess. Oh well, it works. That's all I can ask for in this day and age.

For reference I didn't exactly move the game folder after installation, but the hard drive it's on had to be moved into my new PC after the old one finally burned out on me, so that's likely what caused these issues. I'll have someone who actually knows how this IT stuff works look at it later and sort out any remaining kinks.
Logged