Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Updated the Forum Rules and Guidelines (02/29/20); Blog post: GIF Roundup (04/11/20)

Author Topic: Battle Bug  (Read 151 times)

CapitanJuan

  • Ensign
  • *
  • Posts: 2
    • View Profile
Battle Bug
« on: June 29, 2020, 11:07:12 PM »

Had a problem where a fleet was attacking a base, I joined, we won, then it looked like they were still fighting something so I joined it again, opened the battle screen and it was the dead base just sitting there. Fleets sat there. Only way to exit was to quit campaign.
Logged

Morrokain

  • Admiral
  • *****
  • Posts: 1342
  • Megalith Dreadnought - Archean Order
    • View Profile
Re: Battle Bug
« Reply #1 on: June 29, 2020, 11:43:28 PM »

Any mods installed? If so, it's a good idea to list them. (And there is a subforum for those issues too - separate from this one.)

If not, if you go to the starsector-core directory there should be a starsector.txt file. It would probably be useful for the devs to upload that here to help troubleshoot this if it's some kind of rare vanilla issue.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 16597
    • View Profile
Re: Battle Bug
« Reply #2 on: June 30, 2020, 09:47:47 AM »

I believe this is actually a vanilla bug! IIRC it's fixed for the next release.

Sorry about the trouble :)
Logged

CapitanJuan

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: Battle Bug
« Reply #3 on: June 30, 2020, 04:49:24 PM »

Yes, it’s vanilla. No problem at all Alex! Love the game! First bug I’ve had so far!
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 16597
    • View Profile
Re: Battle Bug
« Reply #4 on: June 30, 2020, 05:06:03 PM »

Thank you, glad you're enjoying it!
Logged