Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Starsector 0.9.1 error  (Read 348 times)

alexwtb234

  • Ensign
  • *
  • Posts: 33
    • View Profile
Starsector 0.9.1 error
« on: March 04, 2020, 04:11:12 PM »

fatal com.fs.starfarer.campaign.starsystem API.add Orbital Station(Ljava/lang/String;Lcom/fs/starfarer/api/SectorEntityToken;FFFLjava/lang/string;Ljava/lang/string;)Lcom/fs/starfarer/api/campaign/SectorEntityToken



Mods: Starsector Rebal AAA_EZFaction
AAA_starsector_FX_core
Boggled AI Core Production
Boggled Terraforming
Console Commands
ExplorerSociety
EZ Damage
GraphicsLib
Kingdom of Terra
LazyLib
Omnifactory
Roider Union
Safety Override mod
Starsector_AI_Overhaul
Starship Legends
Supply Forging














help
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1142
    • View Profile
Re: Starsector 0.9.1 error
« Reply #1 on: March 04, 2020, 04:17:19 PM »

Looks like Explorer Society isn't updated for the most recent version of Starsector.

alexwtb234

  • Ensign
  • *
  • Posts: 33
    • View Profile
RE: Sundog
« Reply #2 on: March 04, 2020, 04:26:27 PM »

sadly even removing explorer society does not solve the error
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1142
    • View Profile
Re: Starsector 0.9.1 error
« Reply #3 on: March 04, 2020, 04:51:07 PM »

Try removing Rebal as well? I didn't notice it in your list at first, but it is also not updated. Some of xenoarph's other mods might not be up to date either. When searching for mods on the forum, you'll want to make sure to only download ones that say [0.9.1a] to the left of the mod's name. That indicates the version of the game the mod is compatible with.

alexwtb234

  • Ensign
  • *
  • Posts: 33
    • View Profile
Re: sundog
« Reply #4 on: March 04, 2020, 04:57:24 PM »

also not working, maybe the game got corrupted, big sad having to reinstal and put all my mods back
Logged

Thaago

  • Global Moderator
  • Admiral
  • *****
  • Posts: 4777
  • Quantum Mechanic
    • View Profile
    • Email
Re: Starsector 0.9.1 error
« Reply #5 on: March 04, 2020, 05:02:40 PM »

The AI overhaul mod is also not updated, so that should be removed. Could you try turning off all of your mods and seeing if the game starts? It is possible your game is corrupted, but far more likely that the mods are simply not compatible with the current game version.

For reference, here is the mod index: http://fractalsoftworks.com/forum/index.php?topic=177.0

Next to each name is the version numbers that Sundog mentioned. Only mods with a blue [.9a] or [.9.1a] will work. Those marked with a red number of a previous version will not.
Logged

alexwtb234

  • Ensign
  • *
  • Posts: 33
    • View Profile
Re: Sundog
« Reply #6 on: March 04, 2020, 05:48:31 PM »

game working normally,, removed all incompatible mods.
Logged