Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Skills and Story Points (07/08/19)

Pages: [1] 2

Author Topic: Error in sound initialization  (Read 3637 times)

00lewnor

  • Lieutenant
  • **
  • Posts: 70
    • View Profile
    • Email
Error in sound initialization
« on: June 25, 2017, 04:24:20 AM »

The popup:

Quote
Error in sound initialization, proceeding with sound disabled.

org.lwjgl.openal.AL10.nalDistanceModel(l)V

Shows up immediately after clicking play Starsector. The game crashes when it finishes loading with:

Quote
Fatal: org.lwjgl.openal.AL10.nalListenerfv(lj)V

Check starsector.log for more info.

Spoiler
22259 [Thread-4] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/particlealpha32sq.png (using cast)
23071 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.UnsatisfiedLinkError: org.lwjgl.openal.AL10.nalListenerfv(IJ)V
java.lang.UnsatisfiedLinkError: org.lwjgl.openal.AL10.nalListenerfv(IJ)V
   at org.lwjgl.openal.AL10.nalListenerfv(Native Method)
   at org.lwjgl.openal.AL10.alListener(AL10.java:685)
   at sound.new.o00000(Unknown Source)
   at com.fs.starfarer.ooOO.I.o00000(Unknown Source)
   at com.fs.starfarer.title.TitleScreenState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
[close]


The game ran fine last week and I don't know what has changed since then. I have uninstalled and reinstalled the game, I had re-downloaded some mods after reinstalling but they were all deactivated.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 15213
    • View Profile
Re: Error in sound initialization
« Reply #1 on: June 25, 2017, 07:02:37 AM »

If you grab OpenAL and install it, here:
https://openal.org/downloads/

That should resolve the problem. If it doesn't, I'd try a clean reinstall of the game - i.e. remove the game folder manually (after saving off anything you care about - mods, screenshots, saves) and then install it.
Logged

00lewnor

  • Lieutenant
  • **
  • Posts: 70
    • View Profile
    • Email
Re: Error in sound initialization
« Reply #2 on: June 25, 2017, 12:53:10 PM »

Installing OpenAL didn't help (the installer finished so fast i'm inclined to think it was already installed) however, mostly on whim, I ran Starsector as administrator and it loaded fine. I assume the cause is Windows Defender that my laptop decided I wanted installed I don't have a clue when (there are times when I want to punch whoever designed windows 10).

So I can work around it by running Starsector as an administrator but is there a correct way to fix this e.g. some way to tell Windows Defender to trust Starsector?
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 15213
    • View Profile
Re: Error in sound initialization
« Reply #3 on: June 25, 2017, 01:37:46 PM »

Glad you got it sorted out!

So I can work around it by running Starsector as an administrator but is there a correct way to fix this e.g. some way to tell Windows Defender to trust Starsector?

Not that I know of, really not familiar with Windows Defender and haven't seen anyone talk about doing that here. Might be possible, though.
Logged

HellBent

  • Ensign
  • *
  • Posts: 30
    • View Profile
    • Email
Re: Error in sound initialization
« Reply #4 on: July 22, 2017, 06:39:09 AM »

Had same issue, was resolved by running as admin as above
Logged

Vayra

  • Admiral
  • *****
  • Posts: 505
  • jangala delenda est
    • View Profile
Re: Error in sound initialization
« Reply #5 on: June 27, 2019, 10:40:20 PM »

Interesting, my copy just started doing this too. Reinstalling normally didn't fix it, nor did a completely clean reinstall (uninstall, delete entire folder incl. mods, restart PC, reinstall), Running as admin still works, however.

E: Oop, clean reinstall didn't fix it either.
« Last Edit: June 27, 2019, 10:46:59 PM by Vayra »
Logged
Kadur Remnant: http://fractalsoftworks.com/forum/index.php?topic=6649
Vayra's Sector: http://fractalsoftworks.com/forum/index.php?topic=16058
Vayra's Ship Pack: http://fractalsoftworks.com/forum/index.php?topic=16059

im gonna push jangala into the sun i swear to god im gonna do it

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 15213
    • View Profile
Re: Error in sound initialization
« Reply #6 on: June 28, 2019, 08:29:57 AM »

Well, that's weird! Let me know if you end up figuring something out, aside from the "run as admin" thing, that is.
Logged

xenoargh

  • Admiral
  • *****
  • Posts: 4815
  • naively breaking things!
    • View Profile
Re: Error in sound initialization
« Reply #7 on: July 02, 2019, 03:01:40 PM »

Yes, you can define exclusions for Windows Defender:  see here.
Logged
Check out my SS projects :)

taerkar

  • Ensign
  • *
  • Posts: 12
    • View Profile
    • Email
Re: Error in sound initialization
« Reply #8 on: July 11, 2019, 03:50:37 PM »

Just got hit by this out of the blue as well. Admin mode got around it.
Logged

DelicateTask

  • Commander
  • ***
  • Posts: 222
    • View Profile
Re: Error in sound initialization
« Reply #9 on: July 13, 2019, 04:45:03 PM »

Me and my GF just booted up the game today and we both got this error. Admin mode gets around it, but it's really weird that we've been playing this game for months with no problem, then POW, problems. Super strange.

Edit: also, in reply to Xeno, I tried setting up an exception and it didn't work for me, but you can always right-click on starsector.exe, click Properties, select the Compatibility tab, and select "Run this program as an administrator" and save. Then you don't have to intentionally run it as an admin every time.

(It seems that adding an exception only prevents the excepted item from being included in virus scans and such, not necessarily granting it any privileges.)
« Last Edit: July 13, 2019, 05:03:53 PM by DelicateTask »
Logged

xenoargh

  • Admiral
  • *****
  • Posts: 4815
  • naively breaking things!
    • View Profile
Re: Error in sound initialization
« Reply #10 on: July 13, 2019, 06:11:08 PM »

Hmm.  This is strange.  I'm running it under Win10, no problems and I didn't have to grant it elevated status.
Logged
Check out my SS projects :)

DelicateTask

  • Commander
  • ***
  • Posts: 222
    • View Profile
Re: Error in sound initialization
« Reply #11 on: July 14, 2019, 06:10:46 AM »

I'm also running Win10, and I don't think my computer has updated in between playing. It's odd that it just suddenly happened.
Logged

LAJ-47FC9

  • Ensign
  • *
  • Posts: 4
    • View Profile
Re: Error in sound initialization
« Reply #12 on: July 15, 2019, 05:19:39 AM »

I got slapped with this one at random, starting last Friday. Unfortunately for me (as seems to be the usual case), none of the fixes are working. Tried reinstalling OpenAL, running in admin mode, removing all other copies of OpenAL on my computer...
Halp. I don't wanna play the game without sound, that's half the atmosphere gone :(
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 15213
    • View Profile
Re: Error in sound initialization
« Reply #13 on: July 15, 2019, 07:36:06 AM »

Hmm. Do you have any idea what changed last Friday? Maybe an automatic update? If so, it might help to know what it did, if there's any clue. Or some other kind of software being installed?

Also, are you 100% sure it's the same issue? The the fixes that seemed to have helped in everyone else's case didn't here makes it seem at least possible that it's might be a slightly different one. Just in case, could you post the stack trace from the starsector.log?

Would also help to know your operating system. I'm assuming windows 10 but would be good to be sure.

And, finally - are you running vanilla or with mods? Assuming it's the same issue, that shouldn't matter, but might be worth running a vanilla game just to test. A reinstall of the game could be worth a shot as well.
Logged

xenoargh

  • Admiral
  • *****
  • Posts: 4815
  • naively breaking things!
    • View Profile
Re: Error in sound initialization
« Reply #14 on: July 15, 2019, 09:22:50 AM »

Maybe these folks have an audio chipset in common; perhaps there was some sort of exploit found utilizing that hardware (or the mobo's in general) that has been patched, requiring elevated permissions? 

It's rather odd that some of us are fine, others suddenly aren't; that strongly implies there's a weird OS/driver-related issue going on here.

If anybody currently experiencing this bug could post your motherboard make / model, that might help.
Logged
Check out my SS projects :)
Pages: [1] 2