Fractal Softworks Forum
March 22, 2017, 07:19:46 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New blog post: Building Better Worlds (2/21/17)
 
   Home   Help Search Login Register  
Pages: 1 2 [3]
  Print  
Author Topic: [0.7.2a] Outer Rim Alliance v0.41 hotfix (15/03/2017)  (Read 3263 times)
NightKev
Lieutenant
**
Posts: 52


View Profile
« Reply #30 on: March 14, 2017, 07:00:04 PM »

"Unbalanced" as in "empty slots on the left and weapons on the right = bad"? Or do the weapons have to be fully symmetrical, with the exact same on both sides?
Logged
Tartiflette
Admiral
*****
Posts: 1985


Kickstarter is not a magic spring of free money!


View Profile Email
« Reply #31 on: March 15, 2017, 12:30:37 AM »

The slots have to be fitted by a weapon of similar size, not the same exact weapon.

Also, HOTFIX for the few issues reported on discord:

       
         Requires LazyLib

This shouldn't break any save.
« Last Edit: March 15, 2017, 12:50:30 AM by Tartiflette » Logged

 
DinoZavarski
Ensign
*
Posts: 33



View Profile Email
« Reply #32 on: March 19, 2017, 03:54:56 PM »

Can't run game with the mod enabled:

Code:
86462 [Thread-5] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error compiling [data.scripts.ORA_modPlugin]
java.lang.RuntimeException: Error compiling [data.scripts.ORA_modPlugin]
at com.fs.starfarer.loading.scripts.ScriptStore$3.run(Unknown Source)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: data.scripts.ORA_modPlugin
at org.codehaus.janino.JavaSourceClassLoader.findClass(JavaSourceClassLoader.java:179)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 2 more

Linux, running with JDK 8u121-64bit. Nexerlin present and patch applied.
« Last Edit: March 19, 2017, 03:59:18 PM by DinoZavarski » Logged

Me no know, me no understand, me just root...
Orikson
Commander
***
Posts: 231

The Never Ending Questioner


View Profile Email
« Reply #33 on: March 19, 2017, 08:10:52 PM »

You need java7.

Have a read here: http://fractalsoftworks.com/forum/index.php?topic=8726
Logged

"A story teller and a trader. Tell me your tales and I'll tell you no lies."
DinoZavarski
Ensign
*
Posts: 33



View Profile Email
« Reply #34 on: March 20, 2017, 01:59:33 AM »

You need java7.

This is bad. Given the number of Nexerlin compatible mods that won't run with jre7 it is better to wait until this one is fixed to work with jre8 before starting game with it.

Still, thank you for the hint. It allowed me to play the missions and see how new ships look in action. Some nice work.
Logged

Me no know, me no understand, me just root...
Tartiflette
Admiral
*****
Posts: 1985


Kickstarter is not a magic spring of free money!


View Profile Email
« Reply #35 on: March 20, 2017, 02:11:26 AM »

JRE7 is the official version of java used by the game. It's the JRE8 mods that need to be recompiled since that version causes stability issues on some systems.
Logged

 
Midnight Kitsune
Admiral
*****
Posts: 1514



View Profile
« Reply #36 on: March 20, 2017, 02:54:49 AM »

You need java7.

This is bad. Given the number of Nexerlin compatible mods that won't run with jre7 it is better to wait until this one is fixed to work with jre8 before starting game with it.

Still, thank you for the hint. It allowed me to play the missions and see how new ships look in action. Some nice work.
THIS is why all modders should use Java 7 and not 8:
http://fractalsoftworks.com/forum/index.php?topic=9960.msg170913#msg170913
http://fractalsoftworks.com/forum/index.php?topic=9922.msg170608#msg170608
http://fractalsoftworks.com/forum/index.php?topic=10705.msg182481#msg182481

http://fractalsoftworks.com/forum/index.php?topic=10661.msg181467#msg181467
Quote
Miscellaneous
  Rewrote game launcher in OpenGL (was in Swing)
   Improves compatibility for certain versions of OS X and Linux
   Allows downgrade to the more stable Java 7
   "legacyLauncher" option in settings.json to use old launcher
  Downgraded to Java 7 (more stable)
Basically it was so s***, even Alex said screw it and went back to JRE 7, even though that meant more work for him due to having to rebuild the launcher if I understand that quote from him correctly
Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
DinoZavarski
Ensign
*
Posts: 33



View Profile Email
« Reply #37 on: March 20, 2017, 04:11:56 AM »

Unfortunately there is no difference at all with latest 64bit JRE7:

Code:
69964 [Thread-5] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error compiling [data.scripts.ORA_modPlugin]
java.lang.RuntimeException: Error compiling [data.scripts.ORA_modPlugin]
at com.fs.starfarer.loading.scripts.ScriptStore$3.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: data.scripts.ORA_modPlugin
at org.codehaus.janino.JavaSourceClassLoader.findClass(JavaSourceClassLoader.java:179)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 2 more
./starsector.sh  63,93s user 6,04s system 81% cpu 1:25,50 total

1 dino@valqk ~/Games/starsector % cat starsector.sh                                                       :(
./jre_linux/bin/java -server -XX:CompilerThreadPriority=1 -XX:+CompilerThreadHintNoPreempt -Djava.library.path=./native/linux -Xms2048m -Xmx4096m -Xss1024k -classpath janino.jar:commons-compiler.jar:commons-compiler-jdk.jar:starfarer.api.jar:starfarer_obf.jar:jogg-0.0.7.jar:jorbis-0.0.15.jar:json.jar:lwjgl.jar:jinput.jar:log4j-1.2.9.jar:lwjgl_util.jar:fs.sound_obf.jar:fs.common_obf.jar:xstream-1.4.2.jar -Dcom.fs.starfarer.settings.paths.saves=./saves -Dcom.fs.starfarer.settings.paths.screenshots=./screenshots -Dcom.fs.starfarer.settings.paths.mods=./mods -Dcom.fs.starfarer.settings.paths.logs=. com.fs.starfarer.StarfarerLauncher

dino@valqk ~/Games/starsector % realpath jre_linux
/home/dino/Games/starsector/jre7_linux_64

dino@valqk ~/Games/starsector % /home/dino/Games/starsector/jre7_linux_64/bin/java -version
java version "1.7.0_80"
Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)

Enabled mods are only ORA and LazyLib

Please don't tell me i need JDK 7 instead of JRE, Oracle is not giving this for free download anymore.
Logged

Me no know, me no understand, me just root...
Histidine
Admiral
*****
Posts: 1357



View Profile Email
« Reply #38 on: March 20, 2017, 04:15:06 AM »

It's a filename case mismatch between the mod_info.json entry and the actual file jars/ORA.jar.
Logged

DinoZavarski
Ensign
*
Posts: 33



View Profile Email
« Reply #39 on: March 20, 2017, 06:17:18 AM »

Thank you, failed to notice there is reference to the .jar there.
Logged

Me no know, me no understand, me just root...
Pages: 1 2 [3]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!