Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: launcher doesn't start (LWJGL & pixel acceleration)  (Read 4028 times)

majorfreak

  • Commander
  • ***
  • Posts: 227
    • View Profile
launcher doesn't start (LWJGL & pixel acceleration)
« on: January 29, 2017, 09:43:17 PM »

i know i know...you've all seen the issues and the troubleshooter has entries for it. read them all. updated drivers, i know the difference between OS 32-bit and color 32-bit display, i have the exact java installed (jre-7u80-windows-x64) and have followed both video and forum bullet points. restarted computer multiple times, updated my brand new nvidia card  (nvidia Geforce GTX 1050 Ti; dxdiag shows no issues) to the proper latest driver (378.49-desktop-win8-win7-64bit-international-whql; clean install even). I also made sure i hadn't buggered with the file type for vmparams.

nothing. nothing works. Starsector was working fine the other day, but i just got a new graphics card...maybe i'd updated java recently in between my last game?? i dunno about that though since i uninstalled all versions of java and you can see below the game's detecting the one Alex said works.
Code
0    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Starting Starsector 0.7.2a-RC3 launcher
32   [main] INFO  com.fs.starfarer.StarfarerLauncher  - Running in C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core
32   [main] INFO  com.fs.starfarer.StarfarerLauncher  - OS: Windows 7 6.1
32   [main] INFO  com.fs.starfarer.StarfarerLauncher  - Java version: 1.7.0_80 (64-bit)
640  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: chatter [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Combat Chatter]
656  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: lw_console [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Console Commands]
687  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: shaderLib [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\GraphicsLib]
702  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: lw_lazylib [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\LazyLib]
702  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: leadingPip [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Leading Pip]
718  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: nexerelin [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Nexerelin]
718  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: portrait [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Portrait pack]
734  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: saveTransfer [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Save Transfer]
734  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: swp [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Ship and Weapon Pack]
749  [main] INFO  com.fs.starfarer.launcher.ModManager  - Found mod: dr_ssp [C:\Program Files (x86)\Fractal Softworks\Starsector\starsector-core\..\mods\Starsector Plus]
905  [main] INFO  com.fs.starfarer.settings.StarfarerSettings  - Loading settings
921  [main] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [ABSOLUTE_AND_CWD: null (data/config/settings.json)]
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 640x480, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 640x480, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 640x480, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 640x480, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x576, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x480, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x480, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x576, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x576, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x480, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x480, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 720x576, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 800x600, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 800x600, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 800x600, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 800x600, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1024x768, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1024x768, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1024x768, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1024x768, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1152x864, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1152x864, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x1024, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x960, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x768, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x800, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x800, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x960, 75Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x1024, 75Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x768, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x720, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x960, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x1024, 60Hz, 16bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x1024, 60Hz, 32bpp
2340 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x960, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1280x720, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1360x768, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1360x768, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1366x768, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1366x768, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1400x1050, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1400x1050, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1440x900, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1440x900, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x1024, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x1024, 59Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x1024, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x1024, 59Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x900, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1600x900, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1680x1050, 59Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1680x1050, 60Hz, 32bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1680x1050, 59Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1680x1050, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1920x1080, 60Hz, 16bpp
2356 [main] INFO  com.fs.starfarer.launcher.opengl.GLLauncher  - Found display mode: 1920x1080, 60Hz, 32bpp
8612 [Thread-2] INFO  com.fs.graphics.L  - Using refresh rate:60
12028 [Thread-2] ERROR com.fs.graphics.L  - Exiting - exception in LWJGL initialization
org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at com.fs.graphics.L.ô00000(Unknown Source)
at com.fs.starfarer.launcher.opengl.GLLauncher$2.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
12059 [Thread-2] FATAL com.fs.starfarer.launcher.opengl.GLLauncher  - java.lang.RuntimeException: Exiting - exception in LWJGL initialization
java.lang.RuntimeException: Exiting - exception in LWJGL initialization
at com.fs.graphics.L.ô00000(Unknown Source)
at com.fs.starfarer.launcher.opengl.GLLauncher$2.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
... 3 more
btw, what's "-Xms1024m -Xmx2048m -Xss1024k" (the last value) in vmparams?
« Last Edit: January 29, 2017, 09:52:18 PM by majorfreak »
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #1 on: January 29, 2017, 09:53:14 PM »

Take a look at this thread (in brief, new driver version broke things):
http://fractalsoftworks.com/forum/index.php?topic=11584.0

Also, if you could give this a shot: add "java.exe" (without the quotes, and with a space after it) to vmparams, and remove the -server part. I believe that will make it work, and it's easier than rolling back the driver verion. Would really appreciate you letting me know if that helps!

btw, what's "-Xms1024m -Xmx2048m -Xss1024k" (the last value) in vmparams?

It's the memory allocated for the stack. Probably not a good idea to change that value.
Logged

majorfreak

  • Commander
  • ***
  • Posts: 227
    • View Profile
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #2 on: January 29, 2017, 10:25:43 PM »

sure thing. java.exe gonna try that first.  (haven't tried anything since i last posted except silly manual installs of the latest driver. no dice)

HO HO!!! it worked, bro.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #3 on: January 29, 2017, 10:27:37 PM »

Nice! Thank you for letting me know and glad you got it working :)
Logged

majorfreak

  • Commander
  • ***
  • Posts: 227
    • View Profile
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #4 on: January 29, 2017, 10:29:56 PM »

thanks for a great game. You might want to let the FAQ guy know to update that section. Why did that solution work?
Logged

travhill20

  • Ensign
  • *
  • Posts: 13
    • View Profile
    • Email
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #5 on: January 30, 2017, 07:00:20 PM »

Experiencing the same issue and removed -server and replaced with java.exe as suggested and works for me as well. THANK YOU
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17100
    • View Profile
Re: launcher doesn't start (LWJGL & pixel acceleration)
« Reply #6 on: January 30, 2017, 07:07:45 PM »

Why did that solution work?

Apparently the new NVIDIA drivers do some special stuff to work with Java and detect whether it's java or not based on the first parameter, more or less.

Experiencing the same issue and removed -server and replaced with java.exe as suggested and works for me as well. THANK YOU

Thank you, glad that seems to work across the board.
Logged