Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Raiding for Fun and Profit (11/27/19)

Pages: 1 [2] 3 4 ... 7

Author Topic: [0.9.1a] GraphicsLib 1.4.1  (Read 163061 times)

facc00

  • Lieutenant
  • **
  • Posts: 84
    • View Profile
    • Email
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #15 on: August 04, 2016, 07:53:24 AM »

GraphicsLib is the new successor of ShaderLib. All mods that previously used ShaderLib should still be compatible with GraphicsLib (due to the intentional backwards compatibility Dark.Revenant has kindly included) or has made adjustments to fit (if any).

The description on the main page that says "Requires ShaderLib" is not wrong, but it isn't right either. Why those requirements hasn't been updated? Well, you know what I'm implying. (No offence intended, please don't blow my ship up!)
[/quote]

Thanks I am definitely not trying to point out anyone's fault I just want to make sure I am doing it correctly.  To me they looked like two separate mods with nothing to do with each other.  The train is gone and its out of sight is how late I got to the party :)
Logged

Weltall

  • Admiral
  • *****
  • Posts: 768
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #16 on: August 04, 2016, 09:17:52 PM »

It is actually ok to say it requires ShaderLib, since this is what it used to require. As soon though as you click to download ShaderLib, you see on the top of the page with red big font;

Quote
NOTICE: This mod is outdated! Click HERE for GraphicsLib.

For better or worse, since it changed "name", mods that have not updated for a while their description, will have ShaderLib as a requirement. This is why Dark.Revenant made sure to point out first thing how it is outdated.

PS: I would ask to make sure too. I always prefer to be safe than sorry >.> (Not to mention I actually had them both loaded the same time, until thankfully it was pointed out to me)
Logged
Ignorance is bliss..

facc00

  • Lieutenant
  • **
  • Posts: 84
    • View Profile
    • Email
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #17 on: August 04, 2016, 09:36:49 PM »

It is actually ok to say it requires ShaderLib, since this is what it used to require. As soon though as you click to download ShaderLib, you see on the top of the page with red big font;

Quote
NOTICE: This mod is outdated! Click HERE for GraphicsLib.

For better or worse, since it changed "name", mods that have not updated for a while their description, will have ShaderLib as a requirement. This is why Dark.Revenant made sure to point out first thing how it is outdated.

PS: I would ask to make sure too. I always prefer to be safe than sorry >.> (Not to mention I actually had them both loaded the same time, until thankfully it was pointed out to me)

;)
Logged

Death_Silence_66

  • Commander
  • ***
  • Posts: 241
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #18 on: August 17, 2016, 07:39:06 AM »

I cannot seem to find GraphicsLib in the mods list on startup. I do not have shaderlib.
Logged

Weltall

  • Admiral
  • *****
  • Posts: 768
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #19 on: August 17, 2016, 02:48:33 PM »

The name is ZZ GraphicsLib in the list of mods. Scroll down all the way down and see if it is there.
Logged
Ignorance is bliss..

Death_Silence_66

  • Commander
  • ***
  • Posts: 241
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #20 on: August 17, 2016, 11:51:38 PM »

I don't see anything like that. It's just not there. Other mods do appear. My download might be incomplete. Within the Graphics Lib mod folder there are 3 files. Data, Graphics, and Change log. Should there be more?
« Last Edit: August 17, 2016, 11:54:28 PM by Death_Silence_66 »
Logged

MesoTroniK

  • Admiral
  • *****
  • Posts: 1390
  • I am going to destroy your ships
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #21 on: August 18, 2016, 02:35:13 AM »

When in doubt, download again.

Logged

Death_Silence_66

  • Commander
  • ***
  • Posts: 241
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #22 on: August 18, 2016, 03:42:15 AM »

Problem fixed. The issue was the program I was using to unzip the files.
Logged

namp007

  • Ensign
  • *
  • Posts: 13
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #23 on: October 23, 2016, 02:58:57 PM »

I have encountered a problem while trying to run the mod, it crashes upon startup:

OS : Win 10
Java: 1.8.0_92-b14
Mods trying to load: LazyLib 2.1, ZZ GraphicsLib

Spoiler
Quote
31678 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error compiling [org.dark.shaders.ShaderModPlugin]
java.lang.RuntimeException: Error compiling [org.dark.shaders.ShaderModPlugin]
   at com.fs.starfarer.loading.scripts.ScriptStore$3.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.dark.shaders.ShaderModPlugin
   at org.codehaus.janino.JavaSourceClassLoader.findClass(JavaSourceClassLoader.java:179)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   ... 2 more
[close]

Tryed replacing it w/ shaderlib (latest release on the shaderlib page) and that seems to have worked, I'll use that instead for the time being.
« Last Edit: October 24, 2016, 01:06:09 AM by namp007 »
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2539
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #24 on: October 24, 2016, 02:09:46 AM »

That's particularly bizarre.  Did the mod unpack correctly?  That error seems to me like Graphics.jar doesn't exist.

Also, you should be using Java 1.7 for Starsector if possible (the "jre" folder in the Starsector main directory).
Logged

LostEnder

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #25 on: October 25, 2016, 11:00:38 AM »

DarkRevenant, I've run across an issue that you might want to see. Somehow, the colors using your mod are all out of whack in the UI, as well as in certain suns and a slight effect on the nebular clouds and ships with blues in them. Also, the colors seem to revert to normal during the quicksave process (while the game is processing). This is a recent change, and it was working correctly before.

Spoiler
[close]
Spoiler
[close]

Troubleshooting:
Disable all other mods - Fail
Re-DL lazylib and graphics lib after deleting old files - Fail
The following tested with the F10 reload:
GRAPHICS_OPTIONS - Disable Shaders - Fail
GRAPHICS_OPTIONS - Enable 64Bit buffer - Fail
GRAPHICS_OPTIONS - Disable Lights - Fail
GRAPHICS_OPTIONS - Disable Bloom - Fail

The only thing I can think of that has changed since I started using this mod was a nvidia driver update to 375.63 for my GTX1060 , but I'm not sure how they'd be tied together. I've tried tweaking the color settings in control panel, to to avail.
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2539
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #26 on: October 25, 2016, 01:02:10 PM »

Disable post processing.  Graphics driver updates often break stuff.
Logged

LostEnder

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #27 on: October 25, 2016, 09:25:27 PM »

Huh, fair enough. Thanks for the help!
Logged

Sun Rise

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #28 on: October 27, 2016, 01:37:42 PM »

Hello everyone!

Im trying to install graphicslib, but the download is giving me a plaintext file that i dont know how to activate. help please?

Thanks!
Logged

DornoDiosMio

  • Ensign
  • *
  • Posts: 30
    • View Profile
Re: [0.7.2a] GraphicsLib 1.0.2
« Reply #29 on: November 29, 2016, 07:17:06 AM »

I filed a ticket with Nvidia about the broken post processing. Hopefully they actually fix it one of these days.

The issue exists in the newest 376.09 driver version from November 28th as well.

I won't hold my breath over it because I don't want to die.

Does playing without post processing have a significant impact on the image quality?

If it does I'll just revert to an older driver until I burn out on Starsector again for a while, lol.

Thanks!
Logged
Pages: 1 [2] 3 4 ... 7