Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Player officer got cloned.  (Read 1243 times)

Euphytose

  • Captain
  • ****
  • Posts: 345
    • View Profile
Player officer got cloned.
« on: December 24, 2015, 02:24:49 AM »

I was piloting a Wolf and got destroyed during the battle, so I sent my shuttle in another ship and proceeded to win. After the battle, the Wolf was repaired, but my officer (me) got sent to the first ship in the fleet, the Onslaught. My Wolf is much further down the line. The problem is that I was also sent back to the Wolf.

So then I had two of me sitting in two ships. I tried to assign another officer but the other me would just use another empty ship, so it wasn't just a visual bug. In the officer screen the real me was in the Onslaught. If I assigned the real me to the ship the other me was in, it would just switch them places.

During battle, without switching commands, I was piloting the Onslaught. But I had two "flagship stars" in the deployment screen.

I had to reload the save otherwise I don't think I could have gotten rid of it.

I tried to replicate it to no avail. First time this happened. The Onslaught had an officer with the same picture as me before it got replaced by me, if that's of any importance. And the levels shown were the correct ones for the clone. Both 49, with the correct skills displayed.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17507
    • View Profile
Re: Player officer got cloned.
« Reply #1 on: December 24, 2015, 01:14:45 PM »

Thank you for the report - couldn't get it to happen, unfortunately, but put in some failsafes that *should* prevent it from happening/fix it if it does. Emphasis on "should", though, since couldn't test it out.
Logged

Clockwork Owl

  • Admiral
  • *****
  • Posts: 753
    • View Profile
    • Starsector South Korean Community
    • Email
Re: Player officer got cloned.
« Reply #2 on: December 24, 2015, 04:42:49 PM »

If happens again, please use SAVE COPY function and reload old save.
Logged