Fractal Softworks Forum
April 21, 2018, 10:11:16 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New blog post: Minefields (03/25/18); The Circle Can’t Be Trusted: Drawing Battlestations (03/14/18); Starsector 0.8.1a is out!
 
   Home   Help Search Login Register  
Pages: 1 ... 6 7 [8] 9
  Print  
Author Topic: [0.8.1a] Artefact  (Read 54269 times)
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #105 on: October 30, 2017, 02:03:46 AM »

If i have updated the Artefact and Looters mods(Version checker ^^), i have added some kitbash of my hand on the subject:
Here:

Descriptions:
Quote
Creator:
-Snrasha: Have made these kitbash sprite
-Nia: Have perfectly fix many things on these sprites.
-Community: For have helped for the story and to be present.

This mod add many Tri Tachyon  Kitbashed Ship for the faction.
They have special shipsystem or structure, they are also rare to see.

Example of their specitify:


Tri-Tachyon's Kitbash Ships:
Spectre(TT) Long Range Support
A tactical laser is nothing, but three?

Fantome(TT)-class Frigate

Automated ship with a Modified SO.

Ombre(TT)-class Fast Carrier

Fast BattleCarrier with a Modified SO.

Farfadet(TT)-class Light CapitalShip

Capable of destroy a Aurora.

SeekerPulse-class Module of Farfadet

You cannot ignore it!

« Last Edit: October 30, 2017, 02:06:29 AM by Snrasha » Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Ahne
Captain
****
Posts: 319



View Profile
« Reply #106 on: October 30, 2017, 09:13:37 AM »

pretty cool system, keep it up
Logged

Snrasha
Captain
****
Posts: 393



View Profile
« Reply #107 on: October 30, 2017, 09:42:57 AM »

pretty cool system, keep it up

This is the vanilla shipsystem, but with orange color and 10 less damage for be useless against fighter, ah ah.

Vanilla emp shipsystem:
   "empDamage":500,
   "damage":100,

Pulse KB emp shipsystem:
   "empDamage":10,
   "damage":30,

Else nothing have be modified except the color.


Small update:
Version 0.4:
-Fix sprite of the Ombre(TT)
-Add the Ghost(TT), not finished.
-Fix somes values.


When i will finish to balance and fix these sprites, i think than i have finish my kitbash mod ^^.

Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Ahne
Captain
****
Posts: 319



View Profile
« Reply #108 on: October 30, 2017, 09:44:53 AM »

And the rotating sphere? Thats your creation or not?
Logged

Snrasha
Captain
****
Posts: 393



View Profile
« Reply #109 on: November 01, 2017, 03:00:03 PM »

And the rotating sphere? Thats your creation or not?
Yes for that. (You can look my Artefact mod and see the list of ship, you can see the Farfadet who have also a rotating thing.)



Descriptions:
Quote
Creator:
-Snrasha: Have made these kitbash sprite
-Nia: Have perfectly fix many things on these sprites.
-Community: For have helped for the story and to be present.

This mod add many Tri Tachyon  Kitbashed Ship for the faction.
They have special shipsystem or structure, they are also rare to see.

Example of their specitify:


Tri-Tachyon's Kitbash Ships:
Lassitude Long Range Support
A tactical laser is nothing, but three?

Coupsur Long Range Support
If tactical laser is not important for you, graviton beam, maybe?

Malice-class Frigate

Semi-Automated ship with a Modified SO.

Athenia-class Fast Carrier

Fast BattleCarrier with a Modified SO.

Cognitif-class Fast Cruiser

A simple cruiser, no?

Lodium-class Light CapitalShip

Capable of destroy a Aurora.

SeekerPulse-class Module of Farfadet

You cannot ignore it!

Changelogs:
Code:
Version 0.7:
-Nerf ships.
-Athenia lost 10 OP.   60 OP are too much.
-Fix descriptions.
-Downsize the Lodium Capital to cruiser. But keep always the "Light capital" tag.
-Modify many variant.
-Add the bignouf! A Lasher variant.
-Modify how work engine, they change color, yeah...


Version 0.61(fix):
-Support Dynasector now.
-Add Nia on the name of author.
-Fix text.
-Upgrade the mission lore.
-Remove AImissile from BDRY for have a my custom!
- Reduce weight of the mod 500 Ko => 300 Ko
-Warning if you have downloaded before the 0.5, break save.

Version 0.6: -Break save.
-Modify Automated per "Semi Automated" for be include on the Lore without problem!
-Modify variant for carrier, like they have less crew.
-Rename all ships.
-Remade all descriptions.
-Add the last ship of the mod: A wing of 3 fighter with graviton beam.
-Merge the hullmod semi-automated with a hidden hullmod who modify thruster and the unstable override on the hullmod: Pulse Core.
-The Lodium OP have be decreased. (170 -> 126)   Reason: The Pulse Core who have a unstable core.
-Reduce the topspeed of Lodium of 10.

Thank for your support!

If you have a problem, do not hesitate to contact me!

Edit: Ok this is not the last update, i have found some idea.
Edit2: I have found a person for merge the mod with a another, prepare to see this mod disappears.
« Last Edit: November 02, 2017, 08:51:52 AM by Snrasha » Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Owl
Ensign
*
Posts: 12


View Profile
« Reply #110 on: December 13, 2017, 01:28:04 AM »

Hi, getting an error with the last looters download got message below;

failed to parse version file "looters .version"
cause: looters.version
expected a ',' or ']' @ 248 [character 5 line R]
Check starsector.log etc..
Logged
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #111 on: December 13, 2017, 01:44:40 AM »

Hi, getting an error with the last looters download got message below;

failed to parse version file "looters .version"
cause: looters.version
expected a ',' or ']' @ 248 [character 5 line R]
Check starsector.log etc..

Sorry, fixed, forgot to launch a campaign with.
Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Owl
Ensign
*
Posts: 12


View Profile
« Reply #112 on: December 13, 2017, 04:07:10 PM »

thanks snrasha  Grin
Logged
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #113 on: December 16, 2017, 05:27:13 AM »

And sorry for so many updates, this month, this is because of the tournament, where i fix many things.

A new version of Artefact is out, 3 time less number of projectile and damage increased for compensed.
After, i need to fix the Looters, but on the futur. ^^
Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Takion Kasukedo
Captain
****
Posts: 408


The Embodiment of Defilement, TakionKasukedo


View Profile
« Reply #114 on: January 08, 2018, 08:53:05 PM »

Something strange is going on with your mod.

I got an Soul-Class Freighter, but everytime I remove it's rearward weapon (Artefact Mono PD ), it disappears from the inventory.

I presume this happens with all of the weapons.
Logged

The Embodiment of Defilement reigns over his part of the galaxy.

FEAR THE CASCADE.
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #115 on: January 09, 2018, 01:47:20 AM »

Something strange is going on with your mod.

I got an Soul-Class Freighter, but everytime I remove it's rearward weapon (Artefact Mono PD ), it disappears from the inventory.

I presume this happens with all of the weapons.

Strange, thank for this report ^^


Edit: this bug do not happens for me.

What is your list mod? x)


EDIT2: Oh, fail, Mono PD do not exist, they are a fail on variant, their are PD for fighter. Sorry xD
There do not disappears, they are on your inventory, but useless x)
« Last Edit: January 09, 2018, 01:55:13 AM by Snrasha » Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #116 on: January 24, 2018, 11:47:54 PM »


Changelogs: WARNING 1.5 is a merge of my two mods to one.
Quote
Version 1.5:
-Break save.
-If you play with Nexerelin, for the moment, you need to copy the Artefact\data\config\exerelinFactionConfig folder on the Nexerelin folder for replace the correct variant.
-Merge with the Looters mod.
-Reduce the spawn of my faction ship on pirate and scavanger.
-Merge these two starsystem to a unique one.


I have decided to merge these two for some reason. And after, they do not cost so many RAM and VRAM, so no problem. (Less than any others factions, i think)
The merge of these two nebulasystem to one is  one of the reason.
Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
OhNoesBunnies
Ensign
*
Posts: 20


View Profile Email
« Reply #117 on: February 05, 2018, 05:11:58 PM »

Odd!

Getting a crash with the latest version of your looters mod; just says "Fatal; Null" and there's no specific error message in the logs related to this.
Logged
Snrasha
Captain
****
Posts: 393



View Profile
« Reply #118 on: February 05, 2018, 09:50:33 PM »

Odd!

Getting a crash with the latest version of your looters mod; just says "Fatal; Null" and there's no specific error message in the logs related to this.

Oh, damn, the thing is than i have not received crash when i have played with this version ><
What is the context of your crash? Thank ^^.

Edit: And i have merged the Looters mod with the Artefact, so break the save.
« Last Edit: February 06, 2018, 03:12:43 AM by Snrasha » Logged

I am pretty bad on english. So, sorry in advance.

Artefact Version 0.8.1a
Two weird faction.

High-Tech Armada Version 0.8.1a
Mod of YuiChan and me about only High-Tech stuff added.
OhNoesBunnies
Ensign
*
Posts: 20


View Profile Email
« Reply #119 on: February 08, 2018, 10:46:43 AM »

Odd!

Getting a crash with the latest version of your looters mod; just says "Fatal; Null" and there's no specific error message in the logs related to this.

Oh, damn, the thing is than i have not received crash when i have played with this version ><
What is the context of your crash? Thank ^^.

Edit: And i have merged the Looters mod with the Artefact, so break the save.

Well, when starting a game with JUST the looters and Nexellerin enabled, it crashes. Without Nexellerin, it does the same thing. Dunno why it's acting like it is! It happens when generating a universe.
Logged
Pages: 1 ... 6 7 [8] 9
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!