Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Painting the Stars (02/07/20); Updated the Forum Rules and Guidelines (02/29/20)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Ablus

Pages: [1]
1
Bug Reports & Support (modded) / Infinite battle & no CR loss
« on: February 14, 2020, 07:50:59 PM »
Mod list:
High Tech Armada 0.7.1e
LazyLib 2.4f
MagicLib 0.28
Nexerelin 0.9.5h
Scy Nation 1.58
Seeker - Unidentified Contact 0.3
SWP 1.10.5
GraphicsLib 1.4.1

The battle takes place at player controlled Chicomoztoc, with star fortress intact. The enemy fleet is something like 8 Cathedrals (SWP), 7 Legions, and other assorted ships. The battle takes about 45 minutes, and after the ships stop coming in, and the claim victory option is nowhere to be seen, I decide to sweep the map from top to bottom, making sure to cover every pixel of it. At this point, around 30 minutes have passed since the last ship was destroyed, and none of the ships have experienced any reduction in CR.

With no ships found, and no ships sent in, I am at this point convinced that it's a bug. I then decided to order a full retreat, and after all the ships had left the battle and the game still insisted I stayed in, I decided to leave my computer for a while. About an hour later, I come back to find the battle still going, with the lone star fortress spinning around as usual.

TL;DR:
The battle does not end after the enemy fleet was defeated, no ships lost any CR, and ordering a full retreat didn't end the battle either. Total battle runtime was about two hours give or take.

Pages: [1]