Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Supplius Maximus

Pages: [1]
1
Bug Reports & Support (modded) / Crash during battle.
« on: December 15, 2019, 12:25:50 PM »
As the title says, during a battle I get a "fatal crash: -1"

This is the console error:

464466 [Thread-11] INFO  sound.H  - Playing music with id [steel_rain.ogg]
466015 [Thread-5] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.ArrayIndexOutOfBoundsException: -1
java.lang.ArrayIndexOutOfBoundsException: -1
   at com.fs.starfarer.combat.entities.ship.A.oOoOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.render(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.render(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.render(Unknown Source)
   at com.fs.starfarer.combat.entities.BaseEntity.render(Unknown Source)
   at com.fs.graphics.LayeredRenderer.renderExcluding(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.render(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Thread.java:745)

Anyone got any ideas as to why this is happening?

2
Modding / A little problem with heavy industries.
« on: October 07, 2019, 02:04:48 PM »
I have an issue with a bug regarding my heavy industries. Basically, while I was wandering around the sector, I got the blueprint of the Hiideran Descendants ship Goliath, thanks to the Vesperon Combine. When I commanded my colonies to build me one, at the end of the month, instead of giving me the ship, even though I had more than enough industrial capability to do so, I received an absurd amount of crew, supplies and fuel, which resulted in a very large, 3.5 million credit expense, despite the ship only being worth about 300000 credits to build. This happened for five or six consecutive months, after which I relented and just stopped trying. I thought this was a bug related to the ship specifically, so I didn't think too much of it.

Now, since I basically finished my current game (Killed Hegemony and the Luddic Church. Persean League and Sindrian Diktat are only left with a few worthless planets and no other faction can even come close to match me) I decided to throw balance out of the window and console commanded me the blueprints of the Zeus, Ares and Nike capital ships from the Ship/Weapon Pack mod. But when I tried to produce them, the same thing happened. I spent far more money than I should have, the ships didn't get built and I only got gargantuan amounts of crew, supplies and fuel. Once again, this happened for multiple consecutive months. So my question is, does anybody have any idea on what might be the reason for this and how to fix it? Any answer would be greatly appreciated.

Pages: [1]