Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Updated the Forum Rules and Guidelines (02/29/20); Blog post: GIF Roundup (04/11/20)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Veronw

Pages: [1] 2
1
Modding / Re: Requesting critique on some sprites
« on: August 28, 2012, 01:26:16 PM »
These remind me of Chronicles of Riddick.. why??!
Urgghh....

0.o I don't even remotely see a resemblance.. lol

2
Modding / Re: Requesting critique on some sprites
« on: August 28, 2012, 01:25:30 PM »
Okay, so I did some adjustments to the image, and this is what I got so far. I imagine going in and doing the pixel by pixel adjustments will be a nightmare but a necessity. Out of curiosity, how does one use vectorization?


3
Modding / Re: Requesting crtique on some sprites
« on: August 28, 2012, 11:16:39 AM »
These are great line drawings and have clearly been a labor of love :)

Here's some specific critique:

1.  You need to blackline the shapes and clearly define them.  At this point, you're going to have to do that with Curves (better than using Contrast) to rough-fix the interior lines.  Don't forget to highlight the edges where it's appropriate; if the panel lines are big enough / deep enough to be visible, they're going to have a bright area where the light catches the corners.
2.  Fix all the anti-aliased jaggies.
3.  The lower wing on the large ship has blurry sections that need have all the lines cleaned up.
4.  Shading needs to be much more explicit and use more contrast.
5.  I'd like to see some details break up the symmetry a little bit in the final edit.  Nothing major; we're talking a few "radio masts" and other small greebles that differentiate both sides.

Basically, this needs a lot of detail work to smooth things out, improve the shading and generally tune it up.

In terms of color choices, I feel the dark blue needs a rethink; perhaps painting it in with some lighter blues in the un-shaded areas will give it a better feel (and it will allow panel lines and details to be seen).  The other colors look like they were hand-drawn and are going to need a lot of strengthening as you roll into the final editing stages, but that can probably wait until things are blacklined.

I have to admit, I am a total photoshop novice, all I really know how to do are textures for 3d models, so actually going in and making an image look more refined is something I am not quite sure how to do. If you could clarify what some of your critique means, it would be most helpful :) And yes, these were definitely a labor of love -.-


Edit: clueless on vectoring as well :D

4
Modding / Re: Requesting crtique on some sprites
« on: August 27, 2012, 11:25:53 PM »
Hmm, may have shot myself in the foot, because all I see now are the flaws in the ships lol :(

5
Modding / Re: Requesting crtique on some sprites
« on: August 27, 2012, 11:09:05 PM »
Hmm didn't notice the line differences between the two ships, I'll go fix that, and as far as the engines go, I have no clue what to do. The engines on the explorer aren't really translatable to the Kanost, but I want to keep a similar design philosophy.. hmm.. Thanks for the praise though :D, will admit to being nervous having my babies out here in the open haha

6
Modding / Requesting critique on some sprites
« on: August 27, 2012, 10:56:20 PM »
Hello all, I have created a couple of sprites over the last few months, as it is a very slow process of kitbashing/painting, and I was hoping to get your opinions on them!

I have two that I feel comfortable posting, with the second ship having a different color as I cannot decide which one I like more. Heavily influenced by Babylon 5, Amarr ships, and a very old ship I drew when I was a kid.

Explorer-Class Capital Ship

This ship by far took the longest out of anything I have done! I intended for it to be a deep range exploration vessel about 1.4km in length. The back wings contain a significant portion of the sensing equipment near the aft command deck, while the front mini wings provide a large bulk of armor to protect the hangers from attack.

Kanost-Class Heavy Cruiser

A dissapointment for me, as I do not feel it is on par with the explorer.. Still, I designed it for a battleship/cruiser role with big solid look in mind, but maintaining that same sort of elegance that the explorer and other ships I made possess. I put two images here because I am not sure which color scheme I like better, the blue one gives it a sort of lethal alien look, almost dark-eldar imo, but the biege/gold fits in the with the faction more.. Hate the engines  ;D (the awful purple rectangles)

Opinions welcome!!

7
Modding / JsonArray[0] Not Found [Solved]
« on: August 26, 2012, 01:25:51 AM »
3901 [Thread-6] ERROR com.fs.starfarer.combat.String  - org.json.JSONException: JSONArray[0] not found.
org.json.JSONException: JSONArray[0] not found.
   at org.json.JSONArray.get(JSONArray.java:204)
   at org.json.JSONArray.getDouble(JSONArray.java:243)
   at com.fs.starfarer.loading.J.Ó00000(Unknown Source)
   at com.fs.starfarer.loading.ShipHullSpecLoader.o00000(Unknown Source)
   at com.fs.starfarer.loading.ShipHullSpecLoader.new(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.super(Unknown Source)
   at com.fs.starfarer.loading.G.o00000(Unknown Source)
   at com.fs.oOOO.A.new(Unknown Source)
   at com.fs.starfarer.combat.String.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Thread.java:619)


 I am now getting this error if I add ANY weapons to any ship with the sf editor.. The ships work perfectly in game so long as I do not add any weapons of any kind.

Edit: I have traced the problem back to the new release of the sf editor, 2.4.2, for some reason it jsonarray errors out on me, rolled back to a previous version and now it works.

8
Modding Resources / Re: Trylobot's ship editor (2.4.5)
« on: August 26, 2012, 12:48:04 AM »
Thank you for the added home key functionality! Works like a charm now, should finally give me the opportunity to get my ships in game!  ;D

9
Modding / Re: Error Concerning Ship Variant
« on: August 24, 2012, 10:37:24 PM »
Alright, tried redoing the variant and ship files again, changed the name, and still will not show up in game.

Here are both files:
https://dl.dropbox.com/u/6381014/Kanost%20Cruiser.ship
https://dl.dropbox.com/u/6381014/Kanost%20Cruiser.variant

edit: I get the impression its a big obvious thing thats sitting in front of my face.

10
Modding / Error Concerning Ship Variant [solved]
« on: August 24, 2012, 08:55:56 PM »
EDIT: Figured it out, it appears that the image I was using was somehow not translating properly with the game, after fixing it in photoshop it worked.


Hello, I have recently been working to add a few ships I have been work on in the game, and after the usual slew of errors on startup I finally managed to get to the mission screen! Except, once I get there, I get a 'cannot locate variant!' error. The oddity is that this is only happening for one of the ships, the other three load up fine individually.

This is the error:

14727 [Thread-6] WARN  com.fs.starfarer.title.ooOO.O0OO  - Error loading mission preview
java.lang.RuntimeException: Ship hull variant [Kano'ost_Cruiser] not found!
   at com.fs.starfarer.loading.o0oO.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.super(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.Õ0Ö000(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.<init>(Unknown Source)
   at com.fs.starfarer.combat.A.o00000(Unknown Source)
   at com.fs.starfarer.title.ooOO.o0oO.addToFleet(Unknown Source)
   at com.fs.starfarer.title.ooOO.o0oO.addToFleet(Unknown Source)
   at data.missions.ex2_mission1.MissionDefinition.defineMission(MissionDefinition.java:30)
   at com.fs.starfarer.title.ooOO.o0oO.<init>(Unknown Source)
   at com.fs.starfarer.title.ooOO.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.title.ooOO.J.o00000(Unknown Source)
   at com.fs.starfarer.ui.ooOO.new.o00000(Unknown Source)
   at com.fs.starfarer.ui.ooOO.super.Ò00000(Unknown Source)
   at com.fs.starfarer.title.ooOO.J.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.public.o00000(Unknown Source)
   at com.fs.starfarer.String.int.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.public.o00000(Unknown Source)
   at com.fs.starfarer.ui.p.Object(Unknown Source)
   at com.fs.starfarer.ui.p.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.public.o00000(Unknown Source)
   at com.fs.starfarer.ui.p.Object(Unknown Source)
   at com.fs.starfarer.ui.p.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.public.o00000(Unknown Source)
   at com.fs.starfarer.title.OoOO.o00000(Unknown Source)
   at com.fs.starfarer.A.öOÓ000(Unknown Source)
   at com.fs.oOOO.A.new(Unknown Source)
   at com.fs.starfarer.combat.String.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Thread.java:619)



My assumption was that it was a misplaced apostrophe or a spelling error somewhere, but I have triple checked everything and there are no such errors. I have attempted to place the .variant file in various folders thinking it could be an error in locating it but that has not worked either. I am quite confused as to why this particular ship file is causing errors while the others are not.

Help would be appreciated  :)

11
Modding Resources / Re: Trylobot's ship editor (2.4.5)
« on: August 23, 2012, 06:14:33 PM »
Hello, recently started using your editor and I believe I have found a bug. I am unable to use the escape key to exit out of any of the interface options such as weapon editing or hull editing, I am stuck on those screens. I am curious if this is just on my end or if it could be an issue with the program.

Thanks

12
Modding / Re: Help Desperately Needed
« on: February 24, 2012, 02:37:17 PM »
I figured out the issue, I had apparently duplicated the file for a freighter in the ship.cvs, which didn't allot the number of turrets I had put on it. Copied over one of the cruiser files instead and altered that. Also changed a few other things, got rid of the shields, increased the armor, more battles look more epic that way I think.. Thanks for the assistance all :)

13
Modding / Re: Help Desperately Needed
« on: February 24, 2012, 11:23:09 AM »
Okay, so, having successfully gotten the ship in game, I decided to add another variant of the Valk troop transport, I like the look of it. Got everything set up same way as before, made sure pathing was correct and the like. However, when I try and boot up the mission, I get this error: java.lang.RuntimeException: slot is null - make sure weapon slot id is correct.

Not quite sure what it means, I have redone the hard points on it now twice, perhaps I have too many? Added twelve to the ship..

Help would be appreciated :)

14
Modding / Re: Help Desperately Needed
« on: February 24, 2012, 08:32:49 AM »
Yes, that was what I was originally doing, but after all the trouble I ran into I decided to simplify things as much as possible to find the source of the trouble! I am not sure if I will release it or not as of yet, still gotta get weapons on it  ;D although its working in missions now, which makes me happy!

http://youtu.be/mMq7pQzMtuM rather bad video, but it at least shows what it looks like!

15
Modding / Re: Help Desperately Needed
« on: February 24, 2012, 08:11:57 AM »
{"bounds":[-71.5,-16,-72.5,14,-55.5,41,-18.5,54,-0.5,28,30.5,16,89.5,13,123.5,13,125.5,-10,88.5,-15,30.5,-16,-0.5,-24,-13.5,-50,-53.5,-44],"center":[50,70],"collisionRadius":"200","engineSlots":[{"angle":"180","contrailSize":"64","length":"32","location":[-58,12],"style":"HIGH_TECH","width":"8"},{"angle":"180","contrailSize":"64","length":"32","location":[-58,-9],"style":"HIGH_TECH","width":"8"},{"angle":"180","contrailSize":"64","length":"64","location":[-54,6],"style":"HIGH_TECH","width":"12"},{"angle":"180","contrailSize":"64","length":"64","location":[-55,-3],"style":"HIGH_TECH","width":"12"}],"height":199,"hullId":"vianktau","hullName":"Vianktau","hullSize":"DESTROYER","shieldCenter":[0,1],"shieldRadius":"200","spriteName":"graphics/ex2/ships/vianktau","style":"HIGH_TECH","viewOffset":0,"weaponSlots":[{"angle":"120","arc":"210","id":"WS 001","locations":[-36,40],"mount":"TURRET","size":"SMALL","type":"ENERGY"},{"angle":"60","arc":"210","id":"WS 002","locations":[-20,36],"mount":"TURRET","size":"SMALL","type":"ENERGY"},{"angle":"-60","arc":"210","id":"WS 003","locations":[-40,-39],"mount":"TURRET","size":"SMALL","type":"ENERGY"},{"angle":"240","arc":"210","id":"WS 004","locations":[-21,-35],"mount":"TURRET","size":"SMALL","type":"ENERGY"},{"angle":"180","arc":"150","id":"WS 005","locations":[12,12],"mount":"HARDPOINT","size":"SMALL","type":"ENERGY"},{"angle":"45","arc":"150","id":"WS 006","locations":[12,-12],"mount":"HARDPOINT","size":"SMALL","type":"ENERGY"},{"angle":"-45","arc":"150","id":"WS 007","locations":[104,5],"mount":"HARDPOINT","size":"MEDIUM","type":"ENERGY"},{"angle":"0","arc":"5","id":"WS 008","locations":[104,-3],"mount":"HARDPOINT","size":"MEDIUM","type":"ENERGY"},{"angle":"0","arc":"5","id":"WS 009","locations":[-32,0],"mount":"TURRET","size":"SMALL","type":"ENERGY"}],"width":103}


Added the path/to line that was suggested, game launches now!! Just have to get the ship into a mission or the campaign now haha. Thanks for the assistance :)

Pages: [1] 2